issue456: Github does not work properly

Priority: bug Status: chatting
msg1159 (view) Author: cristian Date: 2013-12-07.06:38:44
So... for instance, when you try to star a project, it will follow a link (404) instead of toggling the star.

I tried enabling the github mode, but it sees to be focused on letting the shortcuts work (which, by the
way don't work correctly (e.g. the useful t shortcut does not work)).
msg1160 (view) Author: retroj Date: 2013-12-07.15:10:12
See if keykill-mode resolves this issue for you.
msg1161 (view) Author: cristian Date: 2013-12-08.23:04:25
Tried keykill-mode and it still does not work. I'm running conkeror on OSX Lion, if that matters.
So, correct me if I'm wrong, but Conkeror uses the same redering engine than Firefox, as well as its
javascript engine... so why do sites look different than in firefox? and why some javascript stuff does
not work?
msg1162 (view) Author: retroj Date: 2013-12-08.23:39:28
> why do sites look different than in firefox?

This is usually due to websites serving different content based on your user-agent string.
msg1163 (view) Author: retroj Date: 2013-12-09.00:09:53
I couldn't reproduce the problem with 'starring' a project.  Tried both
with mouse and with the keyboard ('follow' command), and with both
Conkeror's normal user-agent string, and a Firefox ua-string.  Tested with
current Conkeror HEAD on XULRunner 15.

To be clear, the 'star' button that I tested was the one on the upper
right of a project page, between 'fork' and 'watch'.
msg1164 (view) Author: cristian Date: 2013-12-09.07:23:56
I was using XULrunner 1.9.2

I tried installing conkeror using the latest version (25) and it does not work (xulrunner crashes); I
tried using version 15, and it didn't work either (it complains about not finding libmozglue.dylib).

Then, I followed the Installation based on Firefox and it's working fine. The rendering issues I had
noted are gone, and the starring works perfect.

Just found something that is does not work: when you are on github and press g to jump to another url, it
does nothing. I tried without using any config; using github mode; using key-kill; and it just doesn't
work. I can live with this, so feel free to close this issue. Or if you want, we can investigate this
msg1165 (view) Author: retroj Date: 2013-12-09.11:52:33
Hmm, unable to reproduce that one here, either.
Date User Action Args
2013-12-09 11:52:33retrojsetmessages: + msg1165
2013-12-09 07:23:57cristiansetmessages: + msg1164
2013-12-09 00:09:53retrojsetmessages: + msg1163
2013-12-08 23:39:28retrojsetmessages: + msg1162
2013-12-08 23:04:54cristiansettitle: Still does not work -> Github does not work properly
2013-12-08 23:04:26cristiansetmessages: + msg1161
title: Github site does not work properly -> Still does not work
2013-12-07 15:10:13retrojsetstatus: unread -> chatting
messages: + msg1160
2013-12-07 06:38:45cristiancreate